choix des blocs latéraux ne fonctionne pas dans l’espace privé

TINLOT
le 11 octobre 2019
à 21:43
Rappel du sujet :

Bonjour,

Je viens d’installer un site spip que je travaille sous wamp en local. Tout fonctionne dans le paramétrage du squelette escal, sauf le paramétrage des blocs latéraux et les 5 rubriques qui s’y rapportent. Un message indique "nous n’arrivons pas à trouver la page". J’ai une version 10 de windows et internet explorer. J’ai désinstallé et réinstallé escal, vidé le cache d’internet explorer, rien n’y fait. Auriez-vous des idées ?
Merci

choix des blocs latéraux

Hello

Peux-tu préciser ce que tu entends par "le paramétrage des blocs latéraux et les 5 rubriques qui s’y rapportent" ?
Quel est l’intitulé exact des blocs latéraux que tu veux activer ?
Ne confonds-tu pas avec les 5 rubriques des onglets du bloc central ?

blocs latéraux

Pour répondre à ta question : Quand on va dans l’espace privé, puis dans squelettes, puis escal, on ouvre la page de tous les paramétrages d’escal dans la colonne de gauche. Il y a plusieurs rubriques (généralités, colonne principale, choix des blocs latéraux, etc. Ce sont les 5 thématiques de cette rubrique "choix des blocs latéraux" qui ne s’ouvrent pas (page d’accueil, les rubriques, les articles, le forum du site, et les autres page. S’affiche alors le message "nous n’arrivons pas à ouvrir la page".
Est-ce plus clair ? Merci pour vos réponses

choix des blocs latéraux

Ok je pige mieux mais je ne vois pas d’où ça peut venir.
Essaye de désactiver Escal (ne pas le désinstaller) puis de supprimer Escal des plugins et enfin de le réinstaller.

config escal choix des blocs latéraux défectueuse

Rebonsoir,
Merci beaucoup pour ce tuyau, malheureusement j’ai suivi tes conseils à la lettre mais cela ne change rien...Il s’agit de la version 11 d’EI et windows 10. Escal dernière version, tout comme spip. Je suis perdu...

choix des blocs latéraux

Bon essaye avec Firefox ou Chrome car je me méfie beaucoup de IE.

blocs latéraux

J’y ai pensé mais comment fait on pur changer de navigateur sous spip et wamp serveur ? par exemple pour passer d’IE à firefox ? Merci encore...

choix des blocs latéraux

Cela n’a rien à voir avec Wamp ou Spip.
C’est comme pour un site Internet, tu peux bien l’ouvrir avec n’importe navigateur.
Tu installes Firefox, tu ouvres Firefox et tu écris localhost dans la barre d’adresse ou tu copies/colles l’URL qui est dans IE.

choix des blocs latéraux

Bonjour,
Je me permet d’intervenir étant utilisateur de WampServer.
Il faut modifier les fichiers wampmanager.ini et wampmanager.conf :
Tu dois remplacer dans navigator ="WINDOWS\explorer.exe" ou autre adresse de navigateur par l’adresse de ton navigateur, exemple navigator ="Program Files\Mozilla Firefox\firefox.exe", si tu veux utilisez firefox !

André

choix des blocs latéraux

Petit complément d’info, si tu ne souhaite pas pour l’instant changer de navigateur, tu peux faire des test en ouvrant le navigateur de ton choix et en tapant dans la barre d’url : http://localhost/ , cela ouvrira Wampserver !
André

problème non résolu

Bonsoir,
Merci pour vos conseils. J’ai changé de navigateur et le problème persiste : La configuration des blocs latéraux d’Escal dans l’espace privé du site ne fonctionne toujours pas. Si quelqu’un a une idée je suis preneur...

choix des blocs latéraux

Ok
Que se passe-t-il exactement quand tu cliques sur l’un des items de "Choix des blocs latéraux"
Les autres menus fonctionnent-ils correctement ?

bis repetita

Je te propose de relire mon explication lors de mon deuxième post d’hier dont je fais un copier coller ci dessous :

Pour répondre à ta question : Quand on va dans l’espace privé, puis dans squelettes, puis escal, on ouvre la page de tous les paramétrages d’escal dans la colonne de gauche. Il y a plusieurs rubriques (généralités, colonne principale, choix des blocs latéraux, etc. Ce sont les 5 thématiques de cette rubrique "choix des blocs latéraux" qui ne s’ouvrent pas (page d’accueil, les rubriques, les articles, le forum du site, et les autres page. S’affiche alors le message "nous n’arrivons pas à ouvrir la page".
Est-ce plus clair ? Merci pour vos réponses

choix des blocs latéraux

Oui pardon, je n’avais pas relu.
J’avoue que je sèche sur ce coup-là. Je ne comprends pas pourquoi les autres pages s’ouvrent sans souci mais pas ces 5 là.
Quelle est l’url affichée dans la barre d’adresse quand tu cliques sur "Page d’accueil" par exemple ?

blocs latéraux

Merci beaucoup à toi.
Voici l’url quand je clique sur "page d’accueil" :

http://localhost/Th%c3%a9%c3%a2tre%20La%20Vaillante/ecrire/?exec=configurer_escal&cfg=sommaire_lateral

choix des blocs latéraux

Hmmm ces % me rappellent quelque chose.
Pourrais-tu changer le nom de ton dossier d’accueil en virant espaces et accents. (Remplace les espaces par des underscore)
Attention, il faudra ensuite aller modifier l’url du site dans l’espace privé : Configuration -> Identité du site

blocs latéraux

Le message est identique, j’ai changé comme tu as proposé, en tout attaché sans accents ni espaces.
L’url donne cela :
http://localhost/theatrelavaillante/ecrire/?exec=configurer_escal&cfg=sommaire_lateral

ça fait plus propre mais cela ne règle pas le pb...

blocs latéraux

a mon tour ..........

premièrement as-tu bien reçu notre mail ?
deuxièmement pourrais-tu essayer avec UWAMP

pour info j’utilisais xampp et uwamp sur win dans le temps....

tu es sur de ton zip escal ?

choix des blocs latéraux

Tu as bien le fichier configurer_escal_sommaire_lateral.html dans /escal/formulaires ?
Autre idée, quels sont les droits sur ce fichier et est-ce les mêmes que les autres fichiers du dossier /formulaires ?

blocs latéraux

Oui le fichier existe bien et à la bonne place. J’ai regardé ses propriétés en faisant clic droit, ça semble comme les autres sur le plan sécurité.. ; Qu’appelles tu les droits exactement ?

choix des blocs latéraux

Je parle des droits chmod (lecture - écriture - exécution)

Mais s’ils ont tous les mêmes droits, je ne vois plus ce qui pourrait coincer.

Peut-être, comme le propose spipfactory, essayer un autre serveur local comme uwamp ?

Choix des blocs latéraux

Je rencontre le même problème que Tinlot. A savoir : Quand on va dans l’espace privé, puis dans squelettes, puis escal, on ouvre la page de tous les paramétrages d’escal dans la colonne de gauche. Il y a plusieurs rubriques (généralités, colonne principale, choix des blocs latéraux, etc. Ce sont les 5 thématiques de cette rubrique "choix des blocs latéraux" qui ne s’ouvrent pas (page d’accueil, les rubriques, les articles, le forum du site, et les autres page. S’affiche alors le message "nous n’arrivons pas à ouvrir la page".

Une solution à ce problème a-t-elle été trouvée.

Merci par avance.

ça m’enerve ............ Ze Bloc is out

Yo

le sujet m’interpelle donc je vais essayer de reproduire ça sur une machine perso.

Quel OS utilisé vous ?
Quel serveur local utilisé vous ?
Quel version de SPIP ?
Quel version d’escal ?

Merci pour les infos...

Choix des blocs latéraux

Hello

Il s’agit d’un site en local ou en ligne ?

Choix des blocs latéraux

Merci pour votre réactivité.

J’utilise SPIP 3.2.7 en local avec Escal 4.3.80 système d’exploitation Windows 10

Choix des blocs latéraux

Ok un site en local encore, donc.
Et quel serveur local utilises-tu ?

local local

ouep parceque c’est vraimment ça que je veux tester sur exactement la même machine

Choix des blocs latéraux

J’utilise Wampserver64

Choix des blocs latéraux

Bjr,

WampServer n’est pas très performant avec Win10.

Je l’ai abandonné depuis longtemps au profit de UwAmp bien plus simple et plus clair dans les accès à localhost, phpMyAdmin et fichiers locaux.
Permet en 1 clic de changer de version Php pour les anciens en 5.7, etc...

Choix des blocs latéraux

Je suis passé de WampServer à DevServer et le problème a disparu.

Je profite de cet échange pour remercier chaleureusement Jean-Christophe pour le développement d’Escal ainsi que pour ce site extrêmement pédagogique.

Bon au cas ou ...........

Mais c’est pas possible .................

Il faut le dire comment ............
et en plus il est mobile ........

UWAMP on a dit UWAMP et la je crie UWAMP

au cas ou puisque le site topissime et JC super qu’est ce qu’il dit lui
http://escal.ac-lyon.fr/spip/spip.php?article10&lang=fr

Ayant eu quelques déboires avec Wampserver sous Windows, j’utilise maintenant UwAmp que je trouve bien mais qui nécessite une petite adaptation décrite dans l’étape suivante.

Stéphane MDR

Reagir au sujet
Qui êtes-vous ?
Votre message

Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document