Forum de l’article

Photos au hasard

Qui êtes-vous ?
Votre message

Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document

Rappel de la discussion
inc-photos
luc - le 27 janvier 2013

Je fonctionne sous SPIP 3 et la dernière version d’escal.

J’ai un souci avec l’option affiché une photo au hasard qui ne fonctionne pas... il n’y a rien qui s’affiche dans le cadre prévu à cet effet.

En lisant cet article je vois qu’il faut bien avoir des img et non des docs... et en vérifiant c’est bien cela le problème... lorsque je télécharge des images... je n’ai pas img mais bien doc (même si l’application reconnait bien une image).

Je suis allé sur le site test pour vérifier si cela fonctionnait bien... http://spipfactory.com

Dans l’article album photo galleria il y a bien des images qui sont affichées et l’extension (img) apparait bien mais lorsque j’essaie d’importer sur ce même article un fichier image jpg depuis mon ordinateur... je me retrouve bien avec un doc et non un img.
J’avoue que j’y perds mon latin.
Si quelqu’un a une idée.

inc-photos
luc - le 27 janvier 2013

Je me réponds à moi même....
Je en lisant la suite des commentaires, ce que j’aurais du faire avant... j’ai trouvé une solution que j’ai testée et qui semble fonctionner... les images étaient dans le portfolio... si on les retire l’extension redevient img... et cela fonctionne visiblement...
Merci pour ce site, la plateforme qui permet vraiment de comprendre ce qui se passe et le produit.

inc-photos
luc - le 27 janvier 2013

Par contre, si on clique sur l’image au hasard qui apparait dans la boite on a une erreur 404. On n’arrive donc pas sur l’article dans lequel se trouve cette image.
Je viens de vérifier que cela ne marche pas sur le site spipfactory.
Le lien est

http://spipfactory.com/testescal/spip.php?article0&lang=fr

inc-photos
Jean Christophe Villeneuve - le 28 janvier 2013

Ah oui, bien vu, en effet, il y aun couac, pour ne pas dire un bug !

Je mène l’enquête. Merci pour ce retour.

inc-photos
Jean Christophe Villeneuve - le 30 janvier 2013

Et voilà qui est corrigé comme tu peux le constater sur le site de test